Mobi2Go Payments Outage
Incident Report for Mobi2Go
Resolved
The fix is live and we have confirmed payments are being processed.
Posted Jul 20, 2020 - 06:32 UTC
Identified
The issue has been identified and a fix is being deployed.
Posted Jul 20, 2020 - 06:00 UTC
Investigating
We are investigating an issue affecting stores using Mobi2Go payments resulting in payment forms being unable to load.
Posted Jul 20, 2020 - 05:37 UTC
This incident affected: Mobi2Go Payments.