Delayed Disbursements
Incident Report for Mobi2Go
Resolved
This incident has been resolved.
Posted May 07, 2020 - 08:38 UTC
Investigating
We are currently investigating an issue with Mobi2Go Payments where some disbursements have been delayed; payment processing is not affected and continues to function as expected.
Posted May 04, 2020 - 04:52 UTC
This incident affected: Mobi2Go Payments.