Orders for Windows settings may have been lost
Incident Report for MOBI
Resolved
On Dec 4 at 15:32pm NZT, and for approximately 5 minutes, we experienced elevated error rates on our API. Unfortunately, some failed API requests were incorrectly returning a header which indicated the request had succeeded (an HTTP 200 response code), rather than the HTTP 500 response code that should have accompanied these errors.

A number of Orders for Windows clients received these incorrect responses to their request for dispatcher settings, and understood this response to mean they should reset their settings, and switch to the default printing mode.

To resolve the issue at the time we had to either update the Orders for Windows settings or remotely force a full settings refresh.

We have resolved the core system issue to ensure all API responses return the correct response code, which will ensure this particular issue cannot re-occur. We've also begun additional mitigations to ensure no other, related issues will happen in future:
1) Update Orders for Windows to ensure it only change when explicitly told to change to Print mode
2) Improve our ability to trigger a remote settings refresh for connected clients.
3) Add dispatcher status to your dashboards
Posted Dec 05, 2017 - 08:58 UTC
Identified
Please check the Orders for Windows application in your stores to ensure that it is correctly printing or sending the orders to Pixelpoint. In particular, note that some PixelPoint stores may have been switched to printer settings.

We are investigating how this happened and will update when we have more information. We apologise for the inconvenience.
Posted Dec 04, 2017 - 05:01 UTC